# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!.*googlebot).*(?:bot|crawl|spider)"
test_str = ("Googlebot/2.1 (+http://www.google.com)\n\n"
"Googlebot/2.1 (+http://www.google.com/bot.html)\n\n"
"KHTML, like Gecko; compatible; bingbot\n\n"
"KHTML, like Gecko; compatible; something Else\n\n"
"KHTML, like Gecko; compatible; spider\n\n"
"Googlebot/2.1 (+http://www.google.com) spider\n\n"
"Googlebot/2.1 (+http://www.google.com) crawl\n\n"
"Google bot/2.1 (+http://www.google.com)\n\n"
"bot spider crawl Googlebot/2.1 (+http://www.google.com)")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.