import Foundation
let pattern = #"^(?!.*googlebot).*(?:bot|crawl|spider)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Googlebot/2.1 (+http://www.google.com)
Googlebot/2.1 (+http://www.google.com/bot.html)
KHTML, like Gecko; compatible; bingbot
KHTML, like Gecko; compatible; something Else
KHTML, like Gecko; compatible; spider
Googlebot/2.1 (+http://www.google.com) spider
Googlebot/2.1 (+http://www.google.com) crawl
Google bot/2.1 (+http://www.google.com)
bot spider crawl Googlebot/2.1 (+http://www.google.com)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)