use strict;
my $str = 'Googlebot/2.1 (+http://www.google.com)
Googlebot/2.1 (+http://www.google.com/bot.html)
KHTML, like Gecko; compatible; bingbot
KHTML, like Gecko; compatible; something Else
KHTML, like Gecko; compatible; spider
Googlebot/2.1 (+http://www.google.com) spider
Googlebot/2.1 (+http://www.google.com) crawl
Google bot/2.1 (+http://www.google.com)
bot spider crawl Googlebot/2.1 (+http://www.google.com)';
my $regex = qr/^(?!.*googlebot).*(?:bot|crawl|spider)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}