$re = '/^(?!.*googlebot).*(?:bot|crawl|spider)/mi';
$str = 'Googlebot/2.1 (+http://www.google.com)
Googlebot/2.1 (+http://www.google.com/bot.html)
KHTML, like Gecko; compatible; bingbot
KHTML, like Gecko; compatible; something Else
KHTML, like Gecko; compatible; spider
Googlebot/2.1 (+http://www.google.com) spider
Googlebot/2.1 (+http://www.google.com) crawl
Google bot/2.1 (+http://www.google.com)
bot spider crawl Googlebot/2.1 (+http://www.google.com)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);