# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/,(?=\s*\))//g;t' <<< "item_id IN ( '1','2',) AND nt_id IN ( 'er1','er2',) AND"