import Foundation
let pattern = #",(?=\s*\))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"item_id IN ( '1','2',) AND nt_id IN ( 'er1','er2',) AND"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)