const regex = /,(?=\s*\))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',(?=\\s*\\))', 'g')
const str = `item_id IN ( '1','2',) AND nt_id IN ( 'er1','er2',) AND`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);