re = /,(?=\s*\))/
str = 'item_id IN ( \'1\',\'2\',) AND nt_id IN ( \'er1\',\'er2\',) AND'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result