#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\{((?:[^{}]|(?R))+)\}"
Local $sString = "Eu sou uma string {dentro de uma string {dentro de outra} }" & @CRLF & _
"String {com {vários {níveis {de } chaves}} aninhadas}." & @CRLF & _
"String {com mais {de} um} trecho {com {chaves}}" & @CRLF & _
"String com {chaves {desbalanceadas}" & @CRLF & _
"Chaves {} vazias" & @CRLF & _
"Apenas {um par de} chaves" & @CRLF & _
"Somente abre { chaves."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")