use strict;
my $str = 'Eu sou uma string {dentro de uma string {dentro de outra} }
String {com {vários {níveis {de } chaves}} aninhadas}.
String {com mais {de} um} trecho {com {chaves}}
String com {chaves {desbalanceadas}
Chaves {} vazias
Apenas {um par de} chaves
Somente abre { chaves.';
my $regex = qr/\{((?:[^{}]|(?R))+)\}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}