import re
regex = re.compile(r"\{((?:[^{}]|(?R))+)\}", flags=re.MULTILINE)
test_str = ("Eu sou uma string {dentro de uma string {dentro de outra} }\n"
"String {com {vários {níveis {de } chaves}} aninhadas}.\n"
"String {com mais {de} um} trecho {com {chaves}}\n"
"String com {chaves {desbalanceadas}\n"
"Chaves {} vazias\n"
"Apenas {um par de} chaves\n"
"Somente abre { chaves.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")