re = /\{((?:[^{}]|(?R))+)\}/m
str = 'Eu sou uma string {dentro de uma string {dentro de outra} }
String {com {vários {níveis {de } chaves}} aninhadas}.
String {com mais {de} um} trecho {com {chaves}}
String com {chaves {desbalanceadas}
Chaves {} vazias
Apenas {um par de} chaves
Somente abre { chaves.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end