using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"here([a-z ,]{0,70})((?:(?! word))) (wrong|true) ";
string input = @"any text here my text any text word wrong any text
any text here my text any text true any text
any text here my text any text wrong any text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}