const regex = /here([a-z ,]{0,70})((?:(?! word))) (wrong|true) /gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('here([a-z ,]{0,70})((?:(?! word))) (wrong|true) ', 'gm')
const str = `any text here my text any text word wrong any text
any text here my text any text true any text
any text here my text any text wrong any text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}