import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "here([a-z ,]{0,70})((?:(?! word))) (wrong|true) ";
final String string = "any text here my text any text word wrong any text\n"
+ "any text here my text any text true any text\n"
+ "any text here my text any text wrong any text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}