import re
regex = re.compile(r"here([a-z ,]{0,70})((?:(?! word))) (wrong|true) ", flags=re.MULTILINE)
test_str = ("any text here my text any text word wrong any text\n"
"any text here my text any text true any text\n"
"any text here my text any text wrong any text")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")