re = /here([a-z ,]{0,70})((?:(?! word))) (wrong|true) /m
str = 'any text here my text any text word wrong any text
any text here my text any text true any text
any text here my text any text wrong any text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end