# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\w\s]){2}([^;;])/sa/gm;t' <<< "correct;;1391;;Yoga Liang;;jy3hmq2piajvq8mopys4levre29wpx8399zdmwwy;;40143177177154"