import Foundation
let pattern = #"([\w\s]){2}([^;;])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"correct;;1391;;Yoga Liang;;jy3hmq2piajvq8mopys4levre29wpx8399zdmwwy;;40143177177154"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"sa"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)