using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w\s]){2}([^;;])";
string substitution = @"sa";
string input = @"correct;;1391;;Yoga Liang;;jy3hmq2piajvq8mopys4levre29wpx8399zdmwwy;;40143177177154";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}