$re = '/([\w\s]){2}([^;;])/m';
$str = 'correct;;1391;;Yoga Liang;;jy3hmq2piajvq8mopys4levre29wpx8399zdmwwy;;40143177177154';
$subst = "sa";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;