use strict;
my $str = 'correct;;1391;;Yoga Liang;;jy3hmq2piajvq8mopys4levre29wpx8399zdmwwy;;40143177177154';
my $regex = qr/([\w\s]){2}([^;;])/mp;
my $subst = 'sa';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";