#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[à-ü]"
Local $sString = "÷" & @CRLF & _
"æ" & @CRLF & _
"--- o "á" abaixo está em NFD e não é pego pela regex" & @CRLF & _
"á" & @CRLF & _
"--- já esse em NFC é pego" & @CRLF & _
"á"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")