$re = '/[à-ü]/m';
$str = '÷
æ
--- o "á" abaixo está em NFD e não é pego pela regex
á
--- já esse em NFC é pego
á';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);