using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[à-ü]";
string input = @"÷
æ
--- o ""á"" abaixo está em NFD e não é pego pela regex
á
--- já esse em NFC é pego
á";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}