#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\/[^\/]*\/[^\/]*\/[^\/]*\/[^\/]*\/[^\/]*\/)[^\/]*(\/[^\/]*)"
Local $sString = "/v1/cp/members/XXXX/benefits/XXXXBG-XXXX-XXXX/benefitlist" & @CRLF & _
"/v1/cp/members/XXXX/benefits/XXXXBG-XXXX-XXXX-/excluded" & @CRLF & _
"/v1/cp/members/XXXX/benefits/XXXXUF-XXXX-XXXX-/benefitlist" & @CRLF & _
"/v1/cp/members/XXXX/benefits/XXXXUF-XXXX-XXXX-/excluded" & @CRLF & _
"/v1/cp/members/XXXX/benefits/XXXXUU-XXXX-XXXX-/benefitlist" & @CRLF & _
"/v1/cp/members/XXXX/benefits/XXXXUU-XXXX-XXXX-/excluded" & @CRLF & _
"/v1/cp/members/XXXX/benefits/XXXXXXXX-XXXX-XXXX-/benefitlist" & @CRLF & _
"/v1/cp/members/XXXX/benefits/XXXXXXXX-XXXX-XXXX-/excluded"
Local $sSubst = "\1XXXX\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)