import Foundation
let pattern = #"^(\/[^\/]*\/[^\/]*\/[^\/]*\/[^\/]*\/[^\/]*\/)[^\/]*(\/[^\/]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/v1/cp/members/XXXX/benefits/XXXXBG-XXXX-XXXX/benefitlist
/v1/cp/members/XXXX/benefits/XXXXBG-XXXX-XXXX-/excluded
/v1/cp/members/XXXX/benefits/XXXXUF-XXXX-XXXX-/benefitlist
/v1/cp/members/XXXX/benefits/XXXXUF-XXXX-XXXX-/excluded
/v1/cp/members/XXXX/benefits/XXXXUU-XXXX-XXXX-/benefitlist
/v1/cp/members/XXXX/benefits/XXXXUU-XXXX-XXXX-/excluded
/v1/cp/members/XXXX/benefits/XXXXXXXX-XXXX-XXXX-/benefitlist
/v1/cp/members/XXXX/benefits/XXXXXXXX-XXXX-XXXX-/excluded
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1XXXX\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)