#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*q=0.\d.*"
Local $sString = "Accept-Language: en-US,en;q=0.1" & @CRLF & _
"Accept-Language: q=0.5;en-NZ,en" & @CRLF & _
"Accept-Language: zh-CN,cn;q=0.8" & @CRLF & _
"Accept-Language: zh-CN,cn;q=1.0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")