import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*q=0.\\d.*";
final String string = "Accept-Language: en-US,en;q=0.1\n"
+ "Accept-Language: q=0.5;en-NZ,en\n"
+ "Accept-Language: zh-CN,cn;q=0.8\n"
+ "Accept-Language: zh-CN,cn;q=1.0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}