$re = '/.*q=0.\d.*/m';
$str = 'Accept-Language: en-US,en;q=0.1
Accept-Language: q=0.5;en-NZ,en
Accept-Language: zh-CN,cn;q=0.8
Accept-Language: zh-CN,cn;q=1.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);