use strict;
my $str = 'Accept-Language: en-US,en;q=0.1
Accept-Language: q=0.5;en-NZ,en
Accept-Language: zh-CN,cn;q=0.8
Accept-Language: zh-CN,cn;q=1.0';
my $regex = qr/.*q=0.\d.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}