using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*q=0.\d.*";
string input = @"Accept-Language: en-US,en;q=0.1
Accept-Language: q=0.5;en-NZ,en
Accept-Language: zh-CN,cn;q=0.8
Accept-Language: zh-CN,cn;q=1.0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}