const regex = /.*q=0.\d.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*q=0.\\d.*', 'gm')
const str = `Accept-Language: en-US,en;q=0.1
Accept-Language: q=0.5;en-NZ,en
Accept-Language: zh-CN,cn;q=0.8
Accept-Language: zh-CN,cn;q=1.0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}