use strict;
my $str = '[/something1/something2, /something3/something4]';
my $regex = qr/[//[//]]/p;
my $subst = '$0\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";