import re
regex = re.compile(r"[//[//]]")
test_str = "[/something1/something2, /something3/something4]"
subst = "$0\\n"
result = regex.sub(subst, test_str)
if result:
print(result)