package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{1,6}(?:-\d{0,4})?$`)
var str = `123456-1234
123456-123
123456-12
123456-1
123456-
123456
12345
1234
123
12
1
-
-1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}