re = /^\d{1,6}(?:-\d{0,4})?$/m
str = '123456-1234
123456-123
123456-12
123456-1
123456-
123456
12345
1234
123
12
1
-
-1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end