const regex = /^\d{1,6}(?:-\d{0,4})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{1,6}(?:-\\d{0,4})?$', 'gm')
const str = `123456-1234
123456-123
123456-12
123456-1
123456-
123456
12345
1234
123
12
1
-
-1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}