import re
regex = re.compile(r"^\d{1,6}(?:-\d{0,4})?$", flags=re.MULTILINE)
test_str = ("123456-1234\n"
"123456-123\n"
"123456-12\n"
"123456-1\n"
"123456-\n"
"123456\n"
"12345\n"
"1234\n"
"123\n"
"12\n"
"1\n"
"-\n"
"-1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")