using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.)\n(?!\n)";
string substitution = @"\1 ";
string input = @"I have a text file where lines are trimmed by newline characters.
I want to strip out those single newlines and replace with simple spaces.
But I do not want the double newlines affected.
This line should start after 2 line breaks.
Everything I try inevitably ends up affecting those double new lines too.
This line should also start after 2 line breaks.
This can be solved using lookaheads.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}