# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.)\n(?!\n)"
test_str = ("I have a text file where lines are trimmed by newline characters.\n"
"I want to strip out those single newlines and replace with simple spaces.\n"
"But I do not want the double newlines affected.\n\n"
"This line should start after 2 line breaks.\n"
"Everything I try inevitably ends up affecting those double new lines too.\n\n"
"This line should also start after 2 line breaks.\n"
"This can be solved using lookaheads.")
subst = "\\1 "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.