#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^0$|^(?!0+$)(\d{4}|\d{20}|\d{25})$"
Local $sString = "0" & @CRLF & _
"1" & @CRLF & _
"11" & @CRLF & _
"111" & @CRLF & _
"0100" & @CRLF & _
"0000" & @CRLF & _
"00000000000000000000" & @CRLF & _
"01001010100110010010" & @CRLF & _
"010010101001100100102" & @CRLF & _
"0000000000000000000000000" & @CRLF & _
"0100101010011010201301122" & @CRLF & _
"01001010100110102013011223"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")