const regex = /^0$|^(?!0+$)(\d{4}|\d{20}|\d{25})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0$|^(?!0+$)(\\d{4}|\\d{20}|\\d{25})$', 'gm')
const str = `0
1
11
111
0100
0000
00000000000000000000
01001010100110010010
010010101001100100102
0000000000000000000000000
0100101010011010201301122
01001010100110102013011223`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}