$re = '/^0$|^(?!0+$)(\d{4}|\d{20}|\d{25})$/m';
$str = '0
1
11
111
0100
0000
00000000000000000000
01001010100110010010
010010101001100100102
0000000000000000000000000
0100101010011010201301122
01001010100110102013011223';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);