use strict;
my $str = '0
1
11
111
0100
0000
00000000000000000000
01001010100110010010
010010101001100100102
0000000000000000000000000
0100101010011010201301122
01001010100110102013011223';
my $regex = qr/^0$|^(?!0+$)(\d{4}|\d{20}|\d{25})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}