import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^0$|^(?!0+$)(\\d{4}|\\d{20}|\\d{25})$";
final String string = "0\n"
+ "1\n"
+ "11\n"
+ "111\n"
+ "0100\n"
+ "0000\n"
+ "00000000000000000000\n"
+ "01001010100110010010\n"
+ "010010101001100100102\n"
+ "0000000000000000000000000\n"
+ "0100101010011010201301122\n"
+ "01001010100110102013011223";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}