using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^0$|^(?!0+$)(\d{4}|\d{20}|\d{25})$";
string input = @"0
1
11
111
0100
0000
00000000000000000000
01001010100110010010
010010101001100100102
0000000000000000000000000
0100101010011010201301122
01001010100110102013011223";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}