#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+[a-z\d]$"
Local $sString = "29c" & @CRLF & _
"29" & @CRLF & _
"a" & @CRLF & _
"2" & @CRLF & _
"2425315651252fsaw" & @CRLF & _
"24241jl.421c" & @CRLF & _
"" & @CRLF & _
"29c is fine" & @CRLF & _
"29 is fine" & @CRLF & _
"2425315651252fsaw fails" & @CRLF & _
"24241jl.421c fails"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")