using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+[a-z\d]$";
string input = @"29c
29
a
2
2425315651252fsaw
24241jl.421c
29c is fine
29 is fine
2425315651252fsaw fails
24241jl.421c fails";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}