use strict;
my $str = '29c
29
a
2
2425315651252fsaw
24241jl.421c
29c is fine
29 is fine
2425315651252fsaw fails
24241jl.421c fails';
my $regex = qr/^\d+[a-z\d]$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}